. .


ST 4U 95: Specifying Configuration Map Pre-Reqs

June 15, 2011 8:27:48.491

Today's Smalltalk 4 You looks at specifying the prequisites for a configuration map. For the example map we created for the Counter application, we'll need to make sure that the SUnit library pre-loads. If you have trouble viewing it here in the browser, you can also navigate directly to YouTube. To watch now, click on the image below:

Config Map Pre-Reqs.

If you have trouble viewing that directly, you can click here to download the video directly. If you need the video in a Windows Media format, then download that here.

You can also watch it on YouTube:

Today we'll be going back to the configuration map browser in VA Smalltalk. We created a Configuration Map to load our Counter application and tests together - but we didn't set it up to load the SUnit library if that wasn't already in the image. Today we'll go back and address that. First, open up the browser on the map:

Configuration Maps

To specify pre-requisites, we need to create a new edition. Right click on the 1.0 release, and select Create New Edition:

New Edition

Move the cursor down to the expression pane below, and select Add from the context menu:

Add Configuration Expression

We have to specify a boolean expression here - if it evaluates to true, then the pre-requisite maps in the next pane will be loaded. Typically, we just set this directly to "true", but you can add more complex expressions:

Configuration Expression

Moving one pane to the right, we can now specify configuration maps that should be loaded before the one we are working on - and the load order for them. Pop up the context menu and select Add First. We only have one pre-requisite here - you can change the order if you have more:

Add Pre-requisite

In the window that pops up, move the libraries you need loaded from the left to the right, and then hit "Ok":

Select the Libraries

Now that we've specified the new pre-reqs, we need to release a version. Select the edition in the upper pane and right click - then select Version:

Release New Version

We have been doing all of this work without our library load. With the new edition selected, pop up the context menu again and select Load:


A small window will pop up to tell you what's about to be loaded, and in what order. Simply proceed by pressing "Ok":


And that's it - we've just loaded the new version, along with its pre-reqs.


Need more help? There's a screencast for other topics like this which you may want to watch. Questions? Try the "Chat with James" Google gadget over in the sidebar.

Technorati Tags: , , ,

[st4u95-iPhone.m4v ( Size: 7692706 )]

posted by James Robertson

 Share Tweet This